View Single Post
  #1  
Old 09-16-2010, 12:41 PM
($W3)HUMM3R's Avatar
($W3)HUMM3R ($W3)HUMM3R is offline
Senior Member
 
Join Date: Sep 2009
Location: Sweden
Posts: 584
Default Über low sound?

Advertisement

WE GON' FIND YOU!

Anywayz.
Started my computer just now and the sound is, as the title says, ÜBER LOW!
When I first bought my new headset (Steelseries steelsound 5HV2) I could have the volume at 20 and the sound was high.
After about 1 week I had to have the volume at 50-60 to get the same level of sound.

Now, I have it at 100 and can't even hear the melody in the "bed intruder song".

Wtf is going on? D:

I'm running windows 7 ultimate x64.
Soundcard is Creative SoundBlaster X-fi Elite Pro.

EDIT: Ok, I tested the headphones in my phone and it's them...
Wtf man?
Everybody told me like "WOHA, STEELSERIES IS THE SHIT!!!! WOOOOOO!!!" and that Skullcandy sucks balls.
I beg to differ.
I had my skullcrushers for more than a year before they broke down.
I've had the Steelseries ones for 19 days, not bad eh?

EDIT2: I probably should have checked that before making this thread, shouldn't I? Arrrr...

EDIT3: I FUCKIN' LOL'D!
Just found that minimalistic volume controller on the cord. xD
Where I read about them it said that it didn't have volume control.
I fail at being American.
__________________
S.T.A.L.K.E.R. for life! <3

I WAS THE FIRST PERSON TO JOIN THE NEW VGR FORUMS! (except for Jay) IN YO' FACE!!!

Zeek roolz!!!

Last edited by ($W3)HUMM3R; 09-16-2010 at 01:43 PM.
Reply With Quote

Advertisement